Flickering Image on REVIT

Comments

10 comments

  • Avatar
    Shane Scranton

    Hi Luciano, thanks for trying out Prospect! I'm curious what type of flickering you're experiencing - does the screen actually turn black, or instead does it looks like the image is delayed as you move your head around? If you're trying the basic Revit sample file on a 980m you (in theory) shouldn't have significant frame rate issues. Let me know what the flickering looks/feels like and we can troubleshoot from there.

  • Avatar
    Luciano Araujo

    Hi Shane, thanks for the quick feedback.

    It feels like the frames stutter a little when we turn the head around in a natural way. The frame sequence is not perfectly smooth and it feels like it is jumping very quickly some frames. It is not a big issue but is perceivable. 

    When we turn the head very slowly the effect is perfectly smooth and the VR experience is great.

    It never turns black. 

    Can you recommend any settings we can test?

     

  • Avatar
    Shane Scranton

    Ok great, this does sound like a framerate issue (the necessary frame rate is 90 frames per second, and even if the frame rate drops to ~85 fps you'll perceive some flickering). I have two ideas that might help:

    1. Navigate to the NVIDIA control panel > Manage 3D Settings > and then click on the tab that says Program Settings. Once that window is open, click Add and select the IrisVR Viewer from window that pops up. Once the Viewer is added, scroll down to Power Management Mode and change the option to "Prefer Maximum Performance". See the images below for reference.
    2. The other thing to try is to make the desktop mirrored image smaller. You can do this by holding down Control when clicking Launch in Prospect, and by doing this a dialogue box will open. Make sure "Windowed" is checked, and I would set the resolution to something like 1280x720.

    Hopefully this will give you a bit of a frame rate boost and resolve the issue. If not let me know and we can try some other tricks.



  • Avatar
    Luciano Araujo

    Hi Shane,

    Tried both without noticeable change. 

    Is there any test we can do to check our frame rate and compare to yours?

    Best Regards,

    Luciano

  • Avatar
    Westin Conahan

    Luciano,

    The IrisVR team might have other suggestions when they get a chance to chime in, but the SteamVR application does have a tool under settings that will let you track if any frames are being missed.

    There is also a SteamVR performance test that can help give you an idea of your system capabilities.

    http://store.steampowered.com/app/323910/

    In our office, we have only noticed dropped frame rates on large models, even when running at GTX 1080.

  • Avatar
    Luciano Araujo

    Hi Westin,

    Our machines usually get scores around 6.0 to 6.4 on SteamVR Performance Test. What´s the recommended/usual benchmark at SteamVR Performance Test for Prospect?? What shall we consider as a large model? 

    This juddering when turning the head around is perceivable even with relatively small models (5MB). Sure it increases with larger models but should not be noticeable in smaller ones.

    Curiously when we move forward/backward or look upwards/downwards this juddering does not show up...???

    Best Regards,

    Luciano

     

     

  • Avatar
    Westin Conahan (Edited )

    Luciano,

    It sounds like your video card is likely your bottleneck. The system we use for our Vive scores an 11, but that is mostly due to the GTX 1080 we have running in the system. To really ensure smooth frame rates without jitters, a GTX 980 or greater is recommended. To be fair though, that is for gaming and perhaps the Prospect requirements are a bit lower, but it does take a powerful video card to run anything consistently at 90 frames per second.

    When I say large models, I mean very large Revit models that cover close to a mile of city context with typography and all that.

    I just noticed that you mentioned you're running a GTX 980M. I did some looking around and it looks like that card is not considered VR ready.

    http://www.geforce.com/hardware/technology/vr/system-requirements

    I previously was running a GTX 690 that was almost VR capable, or somewhere in the yellow on the SteamVR test, and I noticed jitters on that system. If you're able, upgrading to one of the new GTX 1070's or 1080's would clear up the frame rate drops you are experiencing. I can say that for us, the GTX 1080 has been a dream.

  • Avatar
    Luciano Araujo

    Westin,

    Though the SteamVR Performance test scores slightly as VR READY that´s my guess too. Unfortunately we cannot switch GPUs because this is a laptop.

    Nevertheless, the overall experience is good and we are doing great progress in opening models from different sources on Vive using Prospect.

    Thanks for the tips. 

    Luciano

  • Avatar
    David Wilner

    Hi Luciano,

    I had a similar problem when I was running a version of Prospect with Sketchup models on a laptop with a 980M.  It was definitely sensitive to the size of the visible model.  It got better, for example, if I turned off the layer that had trees on it.  But it was always there in certain places in the model and especially, as you said, with quick head turns.

    I have since upgraded to a laptop with a full desktop 980 in it (yes, they exist!) and all those problems have gone away.  So my conclusion is that 980M isn't really enough for VR.  It actually doesn't officially meet the spec of the 970 which is lowest recommended GPU.

    Overall, Prospect with the Vive is an amazing and wonderful tool and we just love it.  It is definitely worth investing in the necessary hardware.  We are looking into getting a rig with a 1080 (not a laptop, obviously) since that seems to be the gold standard now.

  • Avatar
    Luciano Araujo

    Hi David,

    You are right. The gtx980m works for now as long as we are still exploring the VR possibilities. When it comes to real work we will certainly move towards a 1080 rig.

    Thank you all guys for the support!

    Best Regards,

    Luciano

Please sign in to leave a comment.